﻿ Активный и Пассивный режимы
Регистрация
Зарегистрироваться
Имя
Пароль
Забыли пароль?
Total users: 118
Total share: 3998 Gb
Подробнее
О проекте Настройки FAQ Скачать Форум Поддержка
Активный и Пассивный режимы

Активный и Пассивный режимы это два разных вида подключения которые определяют, как вы будете подключатся к другим пользователям и порядок получения файлов. Пассивный режим это наиболее простой в использовании и должен работать практически в любых условиях. Но за простоту приходится платить.
Пассивный режим имеет ограничения при соединении (пассивные пользователи не могут подключатся к другим пассивным) и также вызывает дополнительную нагрузку на хаб, так как все связи пассивного режима идут через хаб. Это режим должен использоваться только когда невозможно использовать активный.

Следующая таблица показывает различия между двумя режимами соединения

 | Активный Режим | Пассивный Режим
Поисковые запросы | Напрямую к/от других пользователей | Направляются хабом
Результаты поиска | Максимум 10 от каждого пользователя | Максимум 10 от каждого пользователя
Ограничения соединения | нет | Пассивные пользователи не могут соеденятся с другими пасиивными
Требуемые настройки | Настройки роутера/бранмауэра если используется | нет
Настройка активного режима

Ниже даны описания того как настроить активный режим в зависимости от топологии сети.

Топология A
Компьютер, напрямую подключенный к Интернету через "hub/switch", c динамическим или статическим IP. В данном случае не требуется никаких дополнительных настроек, кроме включения опции Активный режим в настройках. DC++ автоматически определит ваш ip адрес, и использует любой свободный порт. Если вы используете брандмауэр то выберите в DC++ определенный порт. В настройках брандмауэра, разрешите DC++ соединение через указанный порт.

Топология B

Компьютер как часть сети подключенной к Интернету через маршрутизатор. Компьютер имеет статичный или динамический внешний ip адрес. Технологии трансляции адресов (например NAT) не используются. Активный режим настраивается аналогично топологии А.

Топология C

Компьютер подключенный к Интернету через маршрутизатор или шлюз которые используют технологию NAT (Network Address Translation). NAT это технология позволяющая нескольким компьютерам получать доступ в сеть через единственный ip адрес. В таком случае компьютер имеет собственный внутрисетевой ip (адреса начинающиеся на 192.168.*.*, 10.*.*.* или 172.[16-31].*.*). Домашние сети обычно используют данный вид подключения. Настройка активного режима требует двух шагов:

* Настройка переадресации портов на
маршрутизаторе/шлюзе.
* Настройка активного режима в StrongDC++.

Настройка переадресации портов

К сожалению процесс настройки переадресации называется по разному у различных производителей маршрутизаторов. Он может называться: port mapping, virtual servers или другими синонимами. Не важно как они называются, все они используют один принцип. Его идея состоит в следующем: маршрутизатор настраивается таким образом что соединение на определенный порт на маршрутизатор (порт выбранный вами) переадресуется на конкретную машину внутри сети.

Настройка StrongDC++

В меню "Настройки - Настройки Соединения" выберите Брандмаур с ручной переадресацией(Firewall with manual port forwarding). Введите внешний ip(xx.xx.xx.xx) адрес. Введите номер порта для TCP и UDP, это должны быть порты настроенные на переадресацию в предыдущем разделе.

© Copyright 2005 Ufanet. Created by Oleg V. Kuznetsov [shark]